CVE-2025-5302

Denial of Service (DOS) in JSONReader in run-llama/llama_index

State
Published
Severity
8.6 High
Published
Aug 25, 2025
Updated
Aug 25, 2025
Reserved
May 28, 2025

Read the record on cve.org

Description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Scores

CVSSScoreVectorSource
3.08.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H@huntr_ai

Weaknesses

Affected Products

ProductVersions
run-llama/llama_indexrun-llama
  • before 0.12.38Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.