CVE-2025-54571
ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure
- State
- Published
- Severity
- 6.9 Medium
- Published
- Aug 5, 2025
- Updated
- Nov 3, 2025
- Reserved
- Jul 25, 2025
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 6.9 Medium | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N | GitHub_M |
Weaknesses
- CWE-252 Unchecked Return Value
Affected Products
| Product | Versions |
|---|---|
ModSecurityowasp-modsecurity |
|
References
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-cg44-9m43-3f9v
- https://github.com/owasp-modsecurity/ModSecurity/issues/2514
- https://github.com/owasp-modsecurity/ModSecurity/commit/6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8
- https://lists.debian.org/debian-lts-announce/2025/09/msg00008.html
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.