CVE-2025-58054
Discourse is vulnerable to XSS when quoting chat messages
- State
- Published
- Severity
- 3.5 Low
- Published
- Oct 1, 2025
- Updated
- Oct 1, 2025
- Reserved
- Aug 22, 2025
Description
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.5 Low | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N | GitHub_M |
Weaknesses
- CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
Affected Products
| Product | Versions |
|---|---|
discoursediscourse |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.