CVE-2025-59454

Apache CloudStack: Lack of user permission validation leading to data leak for few APIs

State
Published
Severity
4.3 Medium
Published
Nov 27, 2025
Updated
Nov 28, 2025
Reserved
Sep 16, 2025

Read the record on cve.org

Description

In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory

While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope.

Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.

Scores

CVSSScoreVectorSource
3.14.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NCISA-ADP

Weaknesses

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor

Affected Products

ProductVersions
Apache CloudStackApache Software Foundation
  • 4.0.0 to before 4.20.2Affected
  • 4.21.0 to before 4.22.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.