CVE-2025-59935

GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page

State
Published
Severity
6.5 Medium
Published
Dec 16, 2025
Updated
Dec 16, 2025
Reserved
Sep 23, 2025

Read the record on cve.org

Description

GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.

Scores

CVSSScoreVectorSource
3.16.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
glpiglpi-project
  • >= 10.0.0, < 10.0.21Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.