CVE-2025-64751

OpenFGA Improper Policy Enforcement

State
Published
Severity
5.8 Medium
Published
Nov 21, 2025
Updated
Nov 24, 2025
Reserved
Nov 10, 2025

Read the record on cve.org

Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Scores

CVSSScoreVectorSource
4.05.8 MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:HGitHub_M

Weaknesses

Affected Products

ProductVersions
openfgaopenfga
  • >= 1.4.0, < 1.11.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.