CVE-2025-65199

Windscribe for Linux 'changeMTU' local privilege escalation

State
Published
Severity
7.3 High
Published
Dec 10, 2025
Updated
Dec 18, 2025
Reserved
Nov 18, 2025

Read the record on cve.org

Description

A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.

Scores

CVSSScoreVectorSource
4.07.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:Ncisa-cg
3.17.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:Hcisa-cg

Weaknesses

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Affected Products

ProductVersions
Windscribe for Linux Desktop AppWindscribe
  • 2.10.1 to before 2.18.3-alphaAffected
  • 2.10.1 to before 2.18.8Affected
  • 2.18.3-alphaNot affected
  • 2.18.8Not affected

References

  • urlproduct
  • urlpatch
  • urlpatch
  • urltechnical-descriptionthird-party-advisory
  • url
  • urlgovernment-resourcethird-party-advisory

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.