CVE-2025-65961
Contao is vulnerable to cross-site scripting in templates
- State
- Published
- Severity
- 3.3 Low
- Published
- Nov 25, 2025
- Updated
- Nov 25, 2025
- Reserved
- Nov 18, 2025
Description
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.3 Low | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N | GitHub_M |
Weaknesses
- CWE-87 Improper Neutralization of Alternate XSS Syntax
Affected Products
| Product | Versions |
|---|---|
contaocontao |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.