CVE-2025-66040
Spotipy has a XSS vulnerability in OAuth callback server
- State
- Published
- Severity
- 3.6 Low
- Published
- Nov 26, 2025
- Updated
- Nov 28, 2025
- Reserved
- Nov 21, 2025
Description
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.6 Low | CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N | GitHub_M |
Weaknesses
- CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected Products
| Product | Versions |
|---|---|
spotipyspotipy-dev |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.