CVE-2025-66516

Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected

State
Published
Severity
8.4 High
Published
Dec 4, 2025
Updated
Feb 26, 2026
Reserved
Dec 3, 2025

Read the record on cve.org

Description

Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.

This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways.

First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable.

Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.

Scores

CVSSScoreVectorSource
3.18.4 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hapache

Weaknesses

  • CWE-611 Improper Restriction of XML External Entity Reference

Affected Products

ProductVersions
Apache Tika coreApache Software Foundation
  • 1.13 through 3.2.1Affected
Apache Tika parsersApache Software Foundation
  • 1.13 to before 2.0.0Affected
Apache Tika PDF parser moduleApache Software Foundation
  • 2.0.0 through 3.2.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.