CVE-2025-68615
Net-SNMP snmptrapd crash
- State
- Published
- Severity
- 9.8 Critical
- Published
- Dec 22, 2025
- Updated
- May 1, 2026
- Reserved
- Dec 19, 2025
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 9.8 Critical | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub_M |
Weaknesses
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer
Affected Products
| Product | Versions |
|---|---|
net-snmpnet-snmp |
|
References
- https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq
- https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
- http://www.openwall.com/lists/oss-security/2026/01/09/2
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.