CVE-2025-6981
Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access
- State
- Published
- Severity
- 5.3 Medium
- Published
- Jul 15, 2025
- Updated
- Jul 16, 2025
- Reserved
- Jul 1, 2025
Description
An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 5.3 Medium | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N | GitHub_P |
Weaknesses
- CWE-863 Incorrect Authorization
Affected Products
| Product | Versions |
|---|---|
Enterprise ServerGitHub |
|
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.15release-notes
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.10release-notes
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.6release-notes
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.3release-notes
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.