CVE-2025-71404
better-auth before 1.1.16 Reflected XSS via error parameter
- State
- Published
- Severity
- 5.1 Medium
- Published
- Aug 1, 2026
- Updated
- Aug 3, 2026
- Reserved
- Jul 18, 2026
Description
better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 5.1 Medium | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N | VulnCheck |
Weaknesses
- CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected Products
| Product | Versions |
|---|---|
better-authbetter-auth |
|
References
- GitHub Security Advisory (GHSA-9x4v-xfq5-m8x5)vendor-advisory
- Patch Commitpatch
- VulnCheck Advisory: better-auth before 1.1.16 Reflected XSS via error parameterthird-party-advisory
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.