CVE-2025-9353
Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
- State
- Published
- Severity
- 6.4 Medium
- Published
- Sep 24, 2025
- Updated
- Apr 8, 2026
- Reserved
- Aug 22, 2025
Description
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 6.4 Medium | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N | Wordfence |
Weaknesses
- CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected Products
| Product | Versions |
|---|---|
Themify Builderthemifyme |
|
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js
- https://plugins.trac.wordpress.org/changeset/3366817/
- https://plugins.trac.wordpress.org/changeset/3355757/
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.