CVE-2025-9803

Improper Authentication in lunary-ai/lunary

State
Published
Severity
9.3 Critical
Published
Nov 25, 2025
Updated
Nov 25, 2025
Reserved
Sep 1, 2025

Read the record on cve.org

Description

lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthorized access to user accounts. The issue is resolved in version 1.9.35.

Scores

CVSSScoreVectorSource
3.09.3 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N@huntr_ai

Weaknesses

Affected Products

ProductVersions
lunary-ai/lunarylunary-ai
  • before 1.9.35Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.