CVE-2026-103241

vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service

State
Published
Severity
6.9 Medium
Published
Sep 30, 2026
Updated
Oct 2, 2026
Reserved
Sep 30, 2026

Read the record on cve.org

Description

A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.

Scores

CVSSScoreVectorSource
4.06.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PVulDB
3.15.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:CVulDB
3.05.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:CVulDB
2.05.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P/E:POC/RL:OF/RC:CVulDB

Weaknesses

Affected Products

ProductVersions
vLLMvllm-project
  • 0.1Affected
  • 0.2Affected
  • 0.3Affected
  • 0.4Affected
  • 0.5Affected
  • 0.6Affected
  • 0.7Affected
  • 0.8Affected
  • 0.9Affected
  • 0.10Affected
  • 0.11Affected
  • 0.12Affected
  • 0.13Affected
  • 0.14Affected
  • 0.15Affected
  • 0.16Affected
  • 0.17Affected
  • 0.18Affected
  • 0.19Affected
  • 0.20Affected
  • 0.21Affected
  • 0.22Affected
  • 0.23Affected
  • 0.24Affected
  • 0.25Affected
  • and 2 more versions

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.