CVE-2026-106456

Backstage: Inconsistent credential enforcement for overlapping proxy routes

State
Published
Severity
4.8 Medium
Published
Oct 6, 2026
Updated
Oct 7, 2026
Reserved
Oct 6, 2026

Read the record on cve.org

Description

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

Scores

CVSSScoreVectorSource
3.14.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NGitHub_M

Weaknesses

Affected Products

ProductVersions
backstagebackstage
  • >= 1.28.0, < 1.55.0Affected
plugin-proxy-backend@backstage
  • >= 0.5.0, < 0.6.18Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.