CVE-2026-110679

OpenSIPS rtpproxy rtpproxy_answer out-of-bounds

State
Published
Severity
6.9 Medium
Published
Oct 14, 2026
Updated
Oct 15, 2026
Reserved
Oct 14, 2026

Read the record on cve.org

Description

A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.

Scores

CVSSScoreVectorSource
4.06.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XVulDB
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
3.07.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
2.07.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P/E:ND/RL:OF/RC:CVulDB

Weaknesses

Affected Products

ProductVersions
OpenSIPSn/a
  • 3.6.0Affected
  • 3.6.1Affected
  • 3.6.2Affected
  • 3.6.3Affected
  • 3.6.4Affected
  • 3.6.5Affected
  • 3.6.6Affected
  • 3.6.7Affected
  • 3.6.8Affected
  • 4.0.0Affected
  • 4.0.1Affected
  • 3.6.9Not affected
  • 4.0.2Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.