CVE-2026-112105

GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation

State
Published
Severity
6.3 Medium
Published
Oct 19, 2026
Updated
Oct 19, 2026
Reserved
Oct 18, 2026

Read the record on cve.org

Description

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Scores

CVSSScoreVectorSource
4.06.3 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:XVulDB
3.13.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N/E:X/RL:O/RC:CVulDB
3.03.7 LowCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N/E:X/RL:O/RC:CVulDB
2.02.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N/E:ND/RL:OF/RC:CVulDB

Weaknesses

  • CWE-295 Improper Certificate Validation
  • CWE-287 Improper Authentication

Affected Products

ProductVersions
PassyGlitterWare
  • 1.10.0Affected
  • 1.10.1Affected
  • 1.10.2Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.