CVE-2026-11440

theonedev REST API default-branch improper authorization

State
Published
Severity
5.3 Medium
Published
Jun 6, 2026
Updated
Jun 8, 2026
Reserved
Jun 5, 2026

Read the record on cve.org

Description

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Scores

CVSSScoreVectorSource
4.05.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XVulDB
3.16.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
3.06.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
2.06.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P/E:ND/RL:OF/RC:CVulDB

Weaknesses

Affected Products

ProductVersions
onedevtheonedev
  • 15.0.0Affected
  • 15.0.1Affected
  • 15.0.2Affected
  • 15.0.3Affected
  • 15.0.4Affected
  • 15.0.5Affected
  • 15.0.6Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.