CVE-2026-116675

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization

State
Published
Severity
8.5 High
Published
Oct 27, 2026
Updated
Oct 28, 2026
Reserved
Oct 26, 2026

Read the record on cve.org

Description

TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.

Scores

CVSSScoreVectorSource
4.08.5 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
tinymcetinymce
  • >= 8.5.1, < 8.9.3Affected
  • >= 7.9.3, < 7.9.4Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.