CVE-2026-18245
Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react
- State
- Published
- Severity
- 6.4 Medium
- Published
- Jul 30, 2026
- Updated
- Jul 30, 2026
- Reserved
- Jul 29, 2026
Description
Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318.
To remediate this issue, users should upgrade to version 2.20.6
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 6.4 Medium | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H | AMZN |
| 3.1 | 9.0 Critical | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H | AMZN |
Weaknesses
- CWE-94 Improper Control of Generation of Code ('Code Injection')
Affected Products
| Product | Versions |
|---|---|
Amplify Codegen UIAWS |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.