CVE-2026-18816

Baserow 2FA Verify Endpoint views.py verify improper authentication

State
Published
Severity
2.3 Low
Published
Aug 4, 2026
Updated
Aug 5, 2026
Reserved
Aug 4, 2026

Read the record on cve.org

Description

A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Scores

CVSSScoreVectorSource
4.02.3 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XVulDB
3.15.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
3.05.0 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:CVulDB
2.04.6 MediumAV:N/AC:H/Au:S/C:P/I:P/A:P/E:ND/RL:OF/RC:CVulDB

Weaknesses

Affected Products

ProductVersions
Baserown/a
  • 2.3.0Affected
  • 2.3.1Affected
  • 2.3.2Affected
  • 2.3.3Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.