CVE-2026-19589
Packer vulnerable to arbitrary file write via crafted plugin archive during installation
- State
- Published
- Severity
- 7.1 High
- Published
- Aug 17, 2026
- Updated
- Aug 17, 2026
- Reserved
- Aug 12, 2026
Description
Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.1 High | CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N | HashiCorp |
Weaknesses
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory (Path Traversal)
Affected Products
| Product | Versions |
|---|---|
PackerHashiCorp |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.