CVE-2026-2052

Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

State
Published
Severity
8.8 High
Published
May 2, 2026
Updated
May 4, 2026
Reserved
Feb 6, 2026

Read the record on cve.org

Description

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Scores

CVSSScoreVectorSource
3.18.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HWordfence

Weaknesses

  • CWE-94 Improper Control of Generation of Code ('Code Injection')

Affected Products

ProductVersions
Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgetsmarketingfire
  • 4.2.2 and earlierAffected
Widget Options - ExtendedMarketing Fire, LLC
  • 5.3.2 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.