CVE-2026-23643

CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

State
Published
Severity
5.4 Medium
Published
Jan 16, 2026
Updated
Jan 16, 2026
Reserved
Jan 14, 2026

Read the record on cve.org

Description

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

Scores

CVSSScoreVectorSource
3.15.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
cakephpcakephp
  • >= 5.2.10, < 5.2.12Affected
  • >= 5.3.0, < 5.3.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.