CVE-2026-24733

Apache Tomcat: Security constraint bypass with HTTP/0.9

State
Published
Severity
6.5 Medium
Published
Feb 17, 2026
Updated
Mar 11, 2026
Reserved
Jan 26, 2026

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache Tomcat.

Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112.

Older, EOL versions are also affected.

Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Scores

CVSSScoreVectorSource
3.16.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NCISA-ADP

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache TomcatApache Software Foundation
  • 11.0.0-M1 through 11.0.14Affected
  • 10.1.0-M1 through 10.1.49Affected
  • 9.0.0.M1 through 9.0.112Affected
  • 8.5.100 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.