CVE-2026-27820
zlib: Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption
- State
- Published
- Severity
- 1.7 Low
- Published
- Apr 16, 2026
- Updated
- Apr 16, 2026
- Reserved
- Feb 24, 2026
Description
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 1.7 Low | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U | GitHub_M |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
zlibruby |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.