CVE-2026-29146

Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

State
Published
Severity
7.5 High
Published
Apr 9, 2026
Updated
Aug 17, 2026
Reserved
Mar 4, 2026

Read the record on cve.org

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NCISA-ADP
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:Nredhat-SADP

Weaknesses

  • CWE-209 Generation of Error Message Containing Sensitive Information
  • CWE-642 External Control of Critical State Data
  • CWE-1240 Use of a Cryptographic Primitive with a Risky Implementation

Affected Products

ProductVersions
Apache TomcatApache Software Foundation
  • 11.0.0-M1 through 11.0.18Affected
  • 10.0.0-M1 through 10.1.52Affected
  • 9.0.13 through 9.0.115Affected
  • 8.5.38 through 8.5.100Affected
  • 7.0.100 through 7.0.109Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.