CVE-2026-32264
Craft CMS vulnerable to behavior injection RCE ElementIndexesController and FieldsController
- State
- Published
- Severity
- 8.6 High
- Published
- Mar 16, 2026
- Updated
- Mar 17, 2026
- Reserved
- Mar 11, 2026
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.6 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | GitHub_M |
Weaknesses
- CWE-470 Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')
Affected Products
| Product | Versions |
|---|---|
cmscraftcms |
|
References
- https://github.com/craftcms/cms/security/advisories/GHSA-4484-8v2f-5748
- https://github.com/craftcms/cms/security/advisories/GHSA-7jx7-3846-m7w7
- https://github.com/craftcms/cms/commit/78d181e12e0b15e1300f54ec85f19859d3300f70
- https://github.com/craftcms/cms/commit/dfec46362fcb40b330ce8a4d8136446e65085620
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.