CVE-2026-32990

Apache Tomcat: Fix for CVE-2025-66614 is incomplete

State
Published
Severity
5.3 Medium
Published
Apr 9, 2026
Updated
Apr 10, 2026
Reserved
Mar 17, 2026

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614.

This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115.

Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Scores

CVSSScoreVectorSource
3.15.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NCISA-ADP

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache TomcatApache Software Foundation
  • 11.0.15 through 11.0.19Affected
  • 10.1.50 through 10.1.52Affected
  • 9.0.113 through 9.0.115Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.