CVE-2026-33804
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
- State
- Published
- Severity
- 7.4 High
- Published
- Apr 16, 2026
- Updated
- Apr 16, 2026
- Reserved
- Mar 23, 2026
Description
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.4 High | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N | openjs |
Weaknesses
- CWE-436 Interpretation Conflict
Affected Products
| Product | Versions |
|---|---|
@fastify/middie@fastify/middie |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.