CVE-2026-34356

Apache HTTP Server: ProxyPassReverseCookieMap buffer overflow

State
Published
Severity
7.5 High
Published
Jun 8, 2026
Updated
Jun 8, 2026
Reserved
Mar 27, 2026

Read the record on cve.org

Description

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie*

This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HCISA-ADP

Weaknesses

Affected Products

ProductVersions
Apache HTTP ServerApache Software Foundation
  • 2.4.0 through 2.4.67Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.