CVE-2026-35479

InvenTree Plugin Installation - Insufficient Permissions

State
Published
Severity
6.6 Medium
Published
Apr 8, 2026
Updated
Apr 9, 2026
Reserved
Apr 2, 2026

Read the record on cve.org

Description

InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.

Scores

CVSSScoreVectorSource
3.16.6 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:LGitHub_M

Weaknesses

Affected Products

ProductVersions
InvenTreeinventree
  • < 1.2.7Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.