CVE-2026-39998

Apache APISIX: Identity Injection via forward-auth Plugin Missing Header Cleanup

State
Published
Severity
5.8 Medium
Published
Jun 19, 2026
Updated
Jun 22, 2026
Reserved
Apr 8, 2026

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache APISIX.

The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Scores

CVSSScoreVectorSource
4.05.8 MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:Hapache

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache APISIXApache Software Foundation
  • 2.12.0 through 3.16.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.