CVE-2026-41268
Flowise: Flowise Parameter Override Bypass Remote Command Execution
- State
- Published
- Severity
- 7.7 High
- Published
- Apr 23, 2026
- Updated
- Apr 23, 2026
- Reserved
- Apr 18, 2026
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.0 | 7.7 High | CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L | GitHub_M |
Weaknesses
- CWE-20 Improper Input Validation
Affected Products
| Product | Versions |
|---|---|
FlowiseFlowiseAI |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.