CVE-2026-41869
Apache Nutch: Unauthenticated forced shutdown and job interruption in Nutch Server (Nutch REST API)
- State
- Published
- Severity
- 9.1 Critical
- Published
- Sep 9, 2026
- Updated
- Sep 10, 2026
- Reserved
- Apr 22, 2026
Description
Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST API).
This issue affects Apache Nutch: from 1.10 through 1.22.
Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 9.1 Critical | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H | CISA-ADP |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
Apache NutchApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.