CVE-2026-42089
yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation
- State
- Published
- Severity
- 8.6 High
- Published
- Jun 16, 2026
- Updated
- Jun 16, 2026
- Reserved
- Apr 23, 2026
Description
Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 8.6 High | CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H | GitHub_M |
Weaknesses
- CWE-829 Inclusion of Functionality from Untrusted Control Sphere
Affected Products
| Product | Versions |
|---|---|
environmentyeoman |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.