CVE-2026-43886

Outline: OAuth Scope Validation Logic Error Allows Privilege Escalation to Wildcard API Access

State
Published
Severity
8.2 High
Published
May 11, 2026
Updated
May 12, 2026
Reserved
May 4, 2026

Read the record on cve.org

Description

Outline is a service that allows for collaborative documentation. From 0.84.0 to 1.6.1, a logic error in OAuthInterface.validateScope() uses Array.some() to validate requested OAuth scopes, causing the function to accept the entire scope array if any single scope is valid. An attacker can smuggle the wildcard * scope by requesting scope=read *, escalating a read-only OAuth token to full unrestricted API access including write, delete, and admin operations. This vulnerability is fixed in 1.7.0.

Scores

CVSSScoreVectorSource
3.18.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:NGitHub_M

Weaknesses

  • CWE-269 Improper Privilege Management

Affected Products

ProductVersions
outlineoutline
  • >= 0.84.0, < 1.7.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.