CVE-2026-44185

Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`

State
Published
Severity
7.3 High
Published
Jun 8, 2026
Updated
Sep 14, 2026
Reserved
May 5, 2026

Read the record on cve.org

Description

Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server

This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Scores

CVSSScoreVectorSource
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LCISA-ADP
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:Lredhat-SADP

Weaknesses

Affected Products

ProductVersions
Apache HTTP ServerApache Software Foundation
  • 2.4.0 through 2.4.67Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.