CVE-2026-44541

Fides: DOM-based XSS vulnerability in fides.js via fides_description override

State
Published
Severity
7.0 High
Published
Jun 8, 2026
Updated
Jun 9, 2026
Reserved
May 6, 2026

Read the record on cve.org

Description

Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.

Scores

CVSSScoreVectorSource
4.07.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
fidesethyca
  • >= 2.33.0, < 2.84.5Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.