CVE-2026-45205

Apache Commons Configuration: StackOverflowError for YAML input with cycles

State
Published
Severity
5.3 Medium
Published
May 14, 2026
Updated
May 14, 2026
Reserved
May 11, 2026

Read the record on cve.org

Description

Uncontrolled Recursion vulnerability in Apache Commons.

When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0.

Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Scores

CVSSScoreVectorSource
3.15.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LCISA-ADP

Weaknesses

Affected Products

ProductVersions
Apache Commons ConfigurationApache Software Foundation
  • 2.2 to before 2.15.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.