CVE-2026-5079

multer vulnerable to Denial of Service via deeply nested field names

State
Published
Severity
7.5 High
Published
Jun 15, 2026
Updated
Jun 15, 2026
Reserved
Mar 28, 2026

Read the record on cve.org

Description

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.

Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires.

Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hopenjs

Weaknesses

  • CWE-400 Uncontrolled Resource Consumption

Affected Products

ProductVersions
multermulter
  • 1.0.0 to before 2.2.0Affected
  • 2.2.0Not affected
  • 3.0.0-alpha.1 to before 3.0.0-alpha.2Affected
  • 3.0.0-alpha.2Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.