CVE-2026-55514
vLLM denial of service via prompt embeds on M-RoPE models
- State
- Published
- Severity
- 7.1 High
- Published
- Jul 6, 2026
- Updated
- Jul 6, 2026
- Reserved
- Jun 16, 2026
Description
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 7.1 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | GitHub_M |
Weaknesses
- CWE-617 Reachable Assertion
Affected Products
| Product | Versions |
|---|---|
vllmvllm-project |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.