CVE-2026-65948

Apache Ranger: UnixAuth lacks brute-force protection

State
Published
Severity
7.3 High
Published
Aug 10, 2026
Updated
Aug 10, 2026
Reserved
Jul 23, 2026

Read the record on cve.org

Description

UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0.  Note:  UnixAuth is NOT a recommended option for production deployments.  Users are recommended to upgrade to version 2.9.0, which fixes this issue.

Scores

CVSSScoreVectorSource
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LCISA-ADP

Weaknesses

  • CWE-307 Improper Restriction of Excessive Authentication Attempts

Affected Products

ProductVersions
Apache RangerApache Software Foundation
  • 2.8.0 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.