CVE-2026-7142

Wooey API Endpoint scripts.py add_or_update_script improper authorization

State
Published
Severity
5.3 Medium
Published
Apr 27, 2026
Updated
Apr 27, 2026
Reserved
Apr 26, 2026

Read the record on cve.org

Description

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

Scores

CVSSScoreVectorSource
4.05.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PVulDB
3.16.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:CVulDB
3.06.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:CVulDB
2.06.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P/E:POC/RL:OF/RC:CVulDB

Weaknesses

Affected Products

ProductVersions
Wooeyn/a
  • 0.13.0Affected
  • 0.13.1Affected
  • 0.13.2Affected
  • 0.13.3rc1Not affected
  • 0.14.0Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.