CVE-2026-72831
Grav through 2.0.11 Authentication Bypass via Flex Objects
- State
- Published
- Severity
- 8.7 High
- Published
- Aug 14, 2026
- Updated
- Oct 29, 2026
- Reserved
- Aug 10, 2026
Description
The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.7 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | VulnCheck |
| 3.1 | 8.8 High | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | VulnCheck |
Weaknesses
- CWE-863 Incorrect Authorization
Affected Products
| Product | Versions |
|---|---|
gravgetgrav |
|
grav-plugin-flex-objectstrilbymedia |
|
References
- GitHub Security Advisory (GHSA-pc8m-jxvh-vmrc)vendor-advisory
- Patch Commitpatch
- Patch Commitpatch
- Patch Commitpatch
- Patch Commitpatch
- VulnCheck Advisory: Grav through 2.0.11 Authentication Bypass via Flex Objectsthird-party-advisory
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.