CVE-2026-75015

Apache Syncope: Nested secrets leak cleartext into audit records readable

State
Published
Severity
4.9 Medium
Published
Sep 14, 2026
Updated
Sep 14, 2026
Reserved
Aug 17, 2026

Read the record on cve.org

Description

Insufficiently Protected Credentials vulnerability in Apache Syncope.

Audit events, when sent to the configured store, are not sufficiently masked for the sensitive values they might carry on their payloads, thus allowing administrators to access such sensitive values.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Scores

CVSSScoreVectorSource
3.14.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:NCISA-ADP

Weaknesses

  • CWE-522 Insufficiently Protected Credentials

Affected Products

ProductVersions
Apache SyncopeApache Software Foundation
  • 3.0.0-M0 through 3.0.16Affected
  • 4.0.0-M0 through 4.0.7Affected
  • 4.1.0-M0 through 4.1.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.