CVE-2026-75020
Apache APISIX: ldap-auth plugin cross-subtree identity impersonation
- State
- Published
- Severity
- 7.0 High
- Published
- Aug 27, 2026
- Updated
- Aug 27, 2026
- Reserved
- Aug 17, 2026
Description
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX.
A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach.
This issue affects Apache APISIX: from 2.11.0 through 3.17.0.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 7.0 High | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N | apache |
Weaknesses
- CWE-90 Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection')
Affected Products
| Product | Versions |
|---|---|
Apache APISIXApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.