CVE-2026-75913

CodeWhale before 0.8.64 Argument Injection via git_show

State
Published
Severity
8.5 High
Published
Aug 18, 2026
Updated
Oct 29, 2026
Reserved
Aug 18, 2026

Read the record on cve.org

Description

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

Scores

CVSSScoreVectorSource
4.08.5 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:HVulnCheck
3.19.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:HVulnCheck

Weaknesses

  • CWE-73 External Control of File Name or Path

Affected Products

ProductVersions
CodeWhaleHmbown
  • 0.3.27 through 0.8.41Affected
CodeWhaleHmbown
  • 0.3.27 to before 0.8.41Affected
  • 0.8.41Not affected
CodeWhaleHmbown
  • 0.8.41 to before 0.8.64Affected
  • 0.8.64Not affected
CodeWhaleHmbown
  • 0.8.41 to before 0.8.64Affected
  • 0.8.64Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.